The Galant Center - Powered by vBulletin

Thread: $350 4g64 5 speed swap project started

Page 13 of 14 FirstFirst ... 391011121314 LastLast
Showing results 241 to 260 of 264
  1. #241
    Can someone help me find a cheap 4g64 ecu (Car does not use the following: immobilizer, injector resistor, no injector driver).

  2. #242
    R u looking for a stock auto ecu?

    Sent from my LM-G710 using Tapatalk
    '00 Mitsubishi Galant ES 4g64T (Samantha)
    '01 Mitsubishi Galant ES 4g64 (Daily)
    '02 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '00 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '91 Volvo 740 Turbo B230FT (SOLD)
    '88 Mitsubishi Mighty Max (SOLD)
    '91 Kawasaki ZX7 (SOLD)
    '95 Kawasaki ZX9R

  3. #243
    Quote Originally Posted by spdracr View Post
    R u looking for a stock auto ecu?

    Sent from my LM-G710 using Tapatalk
    I replied to your pm, The answer is yes. Detailed answer in your PM. BTW Thanks for the quick response.
    Last edited by rasheid; 10-17-2018 at 08:36 PM

  4. #244

    Icon14 Does anyone have a 4g63/4g64 shoc ECU dirt cheap?

    Does anyone have a 4g63/4g64 shoc ECU dirt cheap? No immobilizer, no injector resistor, no injector driver, no turbo and no mivec. four connector type(like the evo 4). The vehicle has a TCU separate from the ECU.

    Thanks in advance

  5. #245
    Quote Originally Posted by rasheid View Post
    Does anyone have a 4g63/4g64 shoc ECU dirt cheap? No immobilizer, no injector resistor, no injector driver, no turbo and no mivec. four connector type(like the evo 4). The vehicle has a TCU separate from the ECU.

    Thanks in advance
    I'll reply to you the same I said in pm. No galant ecu has no immobilizer. U are asking for an ecu that does not exist for the 8g buddy.

    Sent from my LM-G710 using Tapatalk
    '00 Mitsubishi Galant ES 4g64T (Samantha)
    '01 Mitsubishi Galant ES 4g64 (Daily)
    '02 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '00 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '91 Volvo 740 Turbo B230FT (SOLD)
    '88 Mitsubishi Mighty Max (SOLD)
    '91 Kawasaki ZX7 (SOLD)
    '95 Kawasaki ZX9R

  6. #246
    I though persons here modded their ecu and deleted the immobilizers on the regular with the tactrix openport cable. If anyone has a spare ecu lying around with a stock 4g63/4g64 sohc rom would greatly appreciate it. Car has been sitting in a garage for months.

  7. #247
    Quote Originally Posted by rasheid View Post
    I though persons here modded their ecu and deleted the immobilizers on the regular with the tactrix openport cable. If anyone has a spare ecu lying around with a stock 4g63/4g64 sohc rom would greatly appreciate it. Car has been sitting in a garage for months.
    Only the 01-03 was able to delete the immobilizer via the tactrix cable.

    Sent from my LM-G710 using Tapatalk
    '00 Mitsubishi Galant ES 4g64T (Samantha)
    '01 Mitsubishi Galant ES 4g64 (Daily)
    '02 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '00 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '91 Volvo 740 Turbo B230FT (SOLD)
    '88 Mitsubishi Mighty Max (SOLD)
    '91 Kawasaki ZX7 (SOLD)
    '95 Kawasaki ZX9R

  8. #248
    BTW i am almost certain the evo 4 ecu dont have immobilizers but is setup for bigger injectors, turbo etc...

    - - - Updated - - -

    What would be my best course of action at this point?

  9. #249
    Quote Originally Posted by rasheid View Post
    BTW i am almost certain the evo 4 ecu dont have immobilizers but is setup for bigger injectors, turbo etc...

    - - - Updated - - -

    What would be my best course of action at this point?
    The evo ecu uses completely different connectors at the harness. Won't directly plug in. Any evo or manual eclipse for that matter won't work.

    Sent from my LM-G710 using Tapatalk
    '00 Mitsubishi Galant ES 4g64T (Samantha)
    '01 Mitsubishi Galant ES 4g64 (Daily)
    '02 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '00 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '91 Volvo 740 Turbo B230FT (SOLD)
    '88 Mitsubishi Mighty Max (SOLD)
    '91 Kawasaki ZX7 (SOLD)
    '95 Kawasaki ZX9R

  10. #250
    Just wanted to update the internet on my findings.
    If your Engine is a 4 cylinder(4g) on a wasted spark system with 210cc injector and separate ECU and TCU (JDM, Some Eur)
    The mirage MR420757 should work, it did for me. It was affordable @ US$50 and didn't have an immobilizer.
    This should work even if you had an immobilizer on the 4g original ecu

  11. #251
    Quote Originally Posted by rasheid View Post
    Just wanted to update the internet on my findings.
    If your Engine is a 4 cylinder(4g) on a wasted spark system with 210cc injector and separate ECU and TCU (JDM, Some Eur)
    The mirage MR420757 should work, it did for me. It was affordable @ US$50 and didn't have an immobilizer.
    This should work even if you had an immobilizer on the 4g original ecu
    We don't have a TCU. Where do you get your information from?

    Sent from my LM-G710 using Tapatalk
    '00 Mitsubishi Galant ES 4g64T (Samantha)
    '01 Mitsubishi Galant ES 4g64 (Daily)
    '02 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '00 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '91 Volvo 740 Turbo B230FT (SOLD)
    '88 Mitsubishi Mighty Max (SOLD)
    '91 Kawasaki ZX7 (SOLD)
    '95 Kawasaki ZX9R

  12. #252
    Haven't updated this in a long time. I've been having transmission issues for a couple weeks now. A shuddering while accelerating in 1st and 2nd gear. Shifting is notchy and fights a little. I thought maybe the clutch master or slave cylinder was internally leaking, so I replaced them last week. Everything seemed to be better until this morning. Sitting at a light, clutch pedal depressed, in 1st, I started easing off of the clutch pedal when the light went green and I started to move forward. Suddenly the clutch fully engaged and caused me to chirp the tires. It now doesn't want to engage any gear even at a standstill. In 1st with the clutch pedal depressed fully, the car still rolls forward. The clutch isn't fully disengaging. I suspect broken pressure plate springs. Time to upgrade! Clutch and flywheel recommendations anyone?? I'm looking at an ACT clutch kit and Clutchmasters flywheel currently. Thoughts on a lightweight flywheel vs. stock? It is my daily driver.

    Sent from my SM-N960U using Tapatalk

  13. #253
    Quote Originally Posted by amaru7 View Post
    Haven't updated this in a long time. I've been having transmission issues for a couple weeks now. A shuddering while accelerating in 1st and 2nd gear. Shifting is notchy and fights a little. I thought maybe the clutch master or slave cylinder was internally leaking, so I replaced them last week. Everything seemed to be better until this morning. Sitting at a light, clutch pedal depressed, in 1st, I started easing off of the clutch pedal when the light went green and I started to move forward. Suddenly the clutch fully engaged and caused me to chirp the tires. It now doesn't want to engage any gear even at a standstill. In 1st with the clutch pedal depressed fully, the car still rolls forward. The clutch isn't fully disengaging. I suspect broken pressure plate springs. Time to upgrade! Clutch and flywheel recommendations anyone?? I'm looking at an ACT clutch kit and Clutchmasters flywheel currently. Thoughts on a lightweight flywheel vs. stock? It is my daily driver.

    Sent from my SM-N960U using Tapatalk
    Stick with exedy stock replacement. No need for any upgrades. You won't benefit anything. Maybe your clutch pedal needs adjustment. Also did you properly bleed your clutch line? What clutch is it in it now? I use the stock flywheel on my racecar and I'm making 450whp so no need for an upgraded flywheel either.

    Sent from my LM-G710 using Tapatalk
    '00 Mitsubishi Galant ES 4g64T (Samantha)
    '01 Mitsubishi Galant ES 4g64 (Daily)
    '02 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '00 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '91 Volvo 740 Turbo B230FT (SOLD)
    '88 Mitsubishi Mighty Max (SOLD)
    '91 Kawasaki ZX7 (SOLD)
    '95 Kawasaki ZX9R

  14. #254
    Quote Originally Posted by spdracr View Post
    Stick with exedy stock replacement. No need for any upgrades. You won't benefit anything. Maybe your clutch pedal needs adjustment. Also did you properly bleed your clutch line? What clutch is it in it now? I use the stock flywheel on my racecar and I'm making 450whp so no need for an upgraded flywheel either.

    Sent from my LM-G710 using Tapatalk
    I did adjust the master cylinder pushrod at the pedal and it made no difference. I do know it's bled correctly. I made sure of that. It's an exedy clutch that I've put just over 30k miles on. Good to know that I can leave the flywheel alone.

    Sent from my SM-N960U using Tapatalk

  15. #255
    Quote Originally Posted by amaru7 View Post
    I did adjust the master cylinder pushrod at the pedal and it made no difference. I do know it's bled correctly. I made sure of that. It's an exedy clutch that I've put just over 30k miles on. Good to know that I can leave the flywheel alone.

    Sent from my SM-N960U using Tapatalk
    I've ran exedy on ever manual swap I did. And I even ran exedy on my first turbo setup and didn't break the fingers on the pressure plate. I'd be surprised that yours broke.

    Sent from my LM-G710 using Tapatalk
    '00 Mitsubishi Galant ES 4g64T (Samantha)
    '01 Mitsubishi Galant ES 4g64 (Daily)
    '02 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '00 Mitsubishi Galant ES 4g64 (SCRAPPED)
    '91 Volvo 740 Turbo B230FT (SOLD)
    '88 Mitsubishi Mighty Max (SOLD)
    '91 Kawasaki ZX7 (SOLD)
    '95 Kawasaki ZX9R

  16. #256
    Quote Originally Posted by spdracr View Post
    I've ran exedy on ever manual swap I did. And I even ran exedy on my first turbo setup and didn't break the fingers on the pressure plate. I'd be surprised that yours broke.

    Sent from my LM-G710 using Tapatalk
    I'm not sure what else it could be. I'll just have to pull the trans and check. Or maybe sneak a bore scope up in there to get a look

    Sent from my SM-N960U using Tapatalk

  17. #257
    Experienced TGC Member xd_01's Avatar
    Join Date
    08-26-2007
    Location
    L.I.N.Y./ Rockville MD
    Posts
    1,145
    That sucks, I hate reinstalling that trans. I hate it so much I just pull the motor out. When you drain the gear oil you screen it and look for any pieces of metal that would show a sign of internal damage.

    I dont know the history of your gearbox or your driving style but I wouldnt rule out some worn bearings inside the trans. Sounds weird for a clutch to give out like that usually they just start slipping like crazy.

    I agree with Alex on replacing with a stock type clutch. Much cheaper and more behaved.

  18. #258
    Quote Originally Posted by xd_01 View Post
    That sucks, I hate reinstalling that trans. I hate it so much I just pull the motor out. When you drain the gear oil you screen it and look for any pieces of metal that would show a sign of internal damage.

    I dont know the history of your gearbox or your driving style but I wouldnt rule out some worn bearings inside the trans. Sounds weird for a clutch to give out like that usually they just start slipping like crazy.

    I agree with Alex on replacing with a stock type clutch. Much cheaper and more behaved.
    I don't really drive it hard. I'm not sure that it could be something internal. I believe the clutch isn't fully disengaging. I've already done the master and slave cylinders. Unless something weird happened with the throw out bearing, I think it has to be an issue with the clutch or pressure plate. Maybe something vibrated loose? I do have all poly mounts. I'm not sure about the transmission history either. It came out of an eclipse that I purchased as a parts car, and it was beat to shit lol

    Sent from my SM-N960U using Tapatalk

  19. #259
    Experienced TGC Member xd_01's Avatar
    Join Date
    08-26-2007
    Location
    L.I.N.Y./ Rockville MD
    Posts
    1,145
    Yea I was gonna mention the throw out bearing but usually it makes a whining sound when they start to go.

  20. #260
    No more guessing is needed. Pulled the trans today. Found the issue. Installed the new clutch, pressure plate, and throw out bearing. Reinstalled the trans. Now I just need to find fluid and everything will be fine

    Sent from my SM-N960U using Tapatalk

Page 13 of 14 FirstFirst ... 391011121314 LastLast

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •